BCP #188 made it easy to say why EDCO's arguments for RSA KEX in TLS 1.3 were unactionable. ECDO (the Enterprise Data Centre Operators, mostly big banks and similar outfits) wanted to use the obsolete RSA key exchange method in TLS 1.3, and sent somebody to argue for this right at the end of the process, years after it was removed - because otherwise they'd have to do a bunch of work, and who wants to do work? Well, too bad, RSA KEX makes surveillance really easy, so we got rid of it.
[1]: https://www.etsi.org/deliver/etsi_ts/103500_103599/10352303/...
Are you? I would expect it's completely moribund.
Here is a vendor implementing TLS 1.3 inspection [1] - they probably don't call it ETS (since there's a CVE attached to it) but it probably implements that exact spec (since ETS only deviates from TLS 1.3 by using a static DH key instead of ephemeral).
[1]: https://symantec-enterprise-blogs.security.com/blogs/product...
Edit:
Here's another vendor that probably does it too: https://blog.gigamon.com/2020/04/15/how-do-you-run-cryptogra...
It's a full proxy. Your client (say, Firefox) connects to their product, which has the real end entity certificate and keys for say, big-bank.example, which will have been provided by the customer who bought this product - and so it can prove satisfactorily that it is big-bank.example. Then the proxy forwards this to the "real" system which does the actual banking or whatever.
This is completely orthogonal to the TLS security design. We have successfully connected to you to a system which can prove it is big-bank.example. No need for static DH.
Should your bank trust third party suppliers with the ability to seamlessly impersonate them? I guess that's up to regulators.
* RFC 1121 "Act One - The Poems". https://www.rfc-editor.org/rfc/rfc1121
* RFC 1983 "Internet Users' Glossary" https://www.rfc-editor.org/rfc/rfc1983
* RFC 2468 "I REMEMBER IANA" https://www.rfc-editor.org/rfc/rfc2468.html - Yes, people kept having fun after RFC 2119.
More goodies at https://www.rfc-editor.org/search/rfc_search_detail.php?sort.... A lot of the April Fool's RFCs are Informational too.
The even older categorized class contains more essays. https://www.rfc-editor.org/search/rfc_search_detail.php?sort...
See also: https://en.wikipedia.org/wiki/Request_for_Comments#History. RFC started out informal!