HNHacker News
TopNewBestAskShowJobs

andrius4669

205 karma · joined October 20, 2014

submissionscomments
andrius4669··on Extreme (X8.79) Solar Flare
https://www.spaceweatherlive.com/en/news/view/541/20240514-x...
andrius4669··on Long Covid brain fog may be due to damaged blood vessels in the brain
NMN
andrius4669··on Intel QuickAssist Technology Zstandard Plugin for Zstandard
any idea how igzip's non-QAT path compares to zlib-ng[1]?

[1] https://github.com/zlib-ng/zlib-ng

andrius4669··on RNA repair mechanism discovered in humans
immune system cells actually share a lot of the same receptor systems as neurons do, and these systems end up influencing each other to significant degree, both ways.

this rabbit hole goes deep...

andrius4669··on SQL:2023 is finished: Here is what's new
NULL is more of a declaration that 'there is no value', than mathematical value on its own. if you compare NULL with something you don't get false, you get NULL (which is often considered same as false).

some implementations carry the same "uncomparable" logic when checking for unique constraints, while others drop the ball here.

programming language wise, it's kinda like null pointer or float NaN, both of which are also occasionally complained about, eg. indexing maps by float values can do bogus things in case of NaNs.

edit: clarified some things

andrius4669··on Jabber.org has migrated to Prosody IM
I've been using it comfortably for years now, what do you mean?
andrius4669··on IPFS and Their Gateways
Verification would require more data than CID itself provides (ipld document layout, chunking algorithm, max chunk sizes...).

See https://github.com/multiformats/cid/issues/22

andrius4669··on Why Apple’s iMessage is winning: teens dread the green text bubble
>an upgraded and open SMS protocol that everyone can plug into

that exists, see https://en.wikipedia.org/wiki/Rich_Communication_Services

andrius4669··on Practical HTTP Header Smuggling: Sneaking Past Reverse Proxies to Attack AWS
You definitely shouldn't strip left side of header, as space preceding that is syntax for header splitting over multiple lines at least in email. Not sure if this applies to http though, but some parsers may do that anyway, and some don't.

Just shows how easy it is to be wrong by being lazy with http parsing.

andrius4669··on Privacy activists oppose EU plans for a GDPR-compliant Whois v2
you can connect using bare IPs with http.
andrius4669··on Audacity may collect “Data necessary for law enforcement, litigation” and more
s/freenet/freenode/
andrius4669··on Yggdrasil – Early-stage implementation of an end-to-end encrypted IPv6 network
It works pretty similar to cjdns, but implementation is not as crashy in my experience, also some transport protocol differences (ygg uses tcp while cjdns does udp), also DHT routing instead of cjdns supernode stuff.

So while usability is pretty similar, they're pretty different underneath.

andrius4669··on JPEG XL
firefox is chrome distribution? that's new to me
andrius4669··on JPEG XL
lossless reversible jpeg recompression seems to be a nod to the fact that jpegs aren't going anywhere.
andrius4669··on Git email flow vs. GitHub flow
>RFC 20452, RFC 20463, RFC 20474, RFC 20485

>RFC 68388

what are these numbers, I don't recall RFCs going into 5 digits yet

andrius4669··on In-kernel WireGuard is on its way to FreeBSD and the pfSense router
Link to relevant announcement email: https://lists.zx2c4.com/pipermail/wireguard/2021-March/00649...

There's also Jason's reply to apparently not-nice feedback of someone from NetGate: https://lists.zx2c4.com/pipermail/wireguard/2021-March/00649...

andrius4669··on Overview of JPEG XL
http://sneyers.info/jxl/ contains some more information

they recently frozen bitstream: https://gitlab.com/wg1/jpeg-xl/-/tags/v0.2

andrius4669··on SQISign
also https://twitter.com/luca_defeo/status/1314573802651688960 https://github.com/SQISign/sqisign
andrius4669··on Libgen Storage Decentralization on IPFS
Does it actually work well? I tried to play with it a while back and while sharing files appeared to work, actually downloading them from other node didn't go that well..
andrius4669··on Nitrokey
USB-C plug would still be complete and standard compliant USB (but not USB-A) plug.
andrius4669··on Is WebP really better than JPEG?
>It's a shame it hasn't been adopted as a singular format yet

it has been. look up avif, you can already sorta try it out on firefox nighty.

andrius4669··on Is WebP really better than JPEG?
>hopefully some day it can be integrated into the standard.

see jpeg-xl

andrius4669··on IETF Response to “LS on New IP, Shaping Future Network”
https://archive.vn/aQzKP

https://dnyuz.com/2020/03/27/china-and-huawei-propose-reinve...

andrius4669··on FLIF – Free Lossless Image Format
yeah. it's partially based on https://github.com/cloudinary/fuif so if you use that part of JPEG XL you'll get something similar out of it.
andrius4669··on Red Hat Expecting X.org to “Go into Hard Maintenance Mode Fairly Quickly”
Untrue in my experience.

Games still can render more FPS than mandated by vsync.

I tried playing sauerbraten (with SDL2) on sway other day, it was butter smooth (no tearing) with vsync off in game, and I felt no input lag unlike when I switch vsync flag on in game which limits FPS.

It probably does triple buffering, but somehow on sway it worked better than triple buffering of intel's xorg driver back when I tried that.

andrius4669··on Linux distros without systemd
Soon there will be.

https://devblogs.microsoft.com/commandline/announcing-wsl-2/

andrius4669··on Binance exchange hackers steal bitcoins worth $41m
>why continue to tolerate bitcoin?

you aren't obliged to use it, are you?

andrius4669··on Linux 5.1 Arrives
https://kernelnewbies.org/LinuxChanges more detailed changelog
andrius4669··on Zstandard v1.4.0
What would be gain?
andrius4669··on WAL-G – fast archival and restoration for PostgreSQL
https://github.com/wal-g/wal-g/graphs/contributors
Page 1 of 2Next →